Subversion 1.7 source not recognized

Hi,

I just had a memory problem with my Intellij EAP while running a local JBoss instance. Therefor I had to kill all java applications.Now I've lost my subversion 1.7 inside my IDE. When looking through the logs, only thing I found was this:

2012-03-26 16:22:20,541 [  38600]   INFO - pl.projectlevelman.NewMappings - Error: activating non existing vcs: svn17

Besided this a number of errors are in the log, but they all seem to be related to the IDETalk component:

2012-03-26 16:21:59,518 [  17577]   INFO - ains.communicator.util.XMLUtil - Error reading /home/jh/.IntelliJIdea11/config/ideTalk/userModel.xml

Any idea on how to re-enable subversion1.7?

Kind regards.

5 comments
Comment actions Permalink

Please go to Settings | Version Control and select "Subversion" as the VCS for the needed directories.

0
Comment actions Permalink

Thanks,

I thought I initially did this through the VCS menu, which wasn't showing the option anymore. Additionally the VCS was showing my project parent directory mapped to 'subversion 1.7' and another entry '<project>' mapped to 'subversion'. Kinda strange that these can be conflicting.

Regards,

0
Comment actions Permalink

Hi,

Just started my EAP again and now svn17 is completely gone. Yesterday I could get it to work with the selector on the settings page, but now that page says '<unknown vcs>svn17' . I still get the errors mentioned above, so nothing new about the error messages.

I'm reinstalling to hopefully get this thing back up....

Kind Regards

0
Comment actions Permalink

svn17 is no longer a separate plugin; use the regular Subversion plugin instead.

0
Comment actions Permalink

I installed the latest EAP, removed my old cache directory (.IntellijIdea11). When recreating the project by importing the pom files, I saw that the svn17 was indeed merged with the normal subversion plugin. The cache dir probably contained something which caused the strange behaviour I had, everything seems to be ok now.

0

Please sign in to leave a comment.