How do I update gradle dependencies?

The gradle support prompted me to try the EAP and I've managed to import a gradle project and all the dependencies have been added to the classpath.

If I make a change to the dependencies for my project (e.g. version update) how do I tell IDEA to update the dependencies?

4 comments

Hi Phill,

It's not possible to do at the moment. Work is in progress, feel free to track IDEA-76142.

Denis

0

Thanks, I'm really looking forward to full gradle support.

Off topic but I'd love to track the issue if I can actually find out how to watch it in YouTRACK, there's nothing obvious in the interface (I'm logged-in) and the help docs mention a "Star on behalf... link" which I can't find..

0

You can just click 'star' button:

watch.png

Denis

0

 

Its five years later and this is still not fixed.   I am surprised it was every felt this was ok and five years later is still not fixed.   This reflects poorly on the product that such a serious bug has not been resolved half a decade later.

0

Please sign in to leave a comment.