Please set the spellchecker inspection disabled as default...

Everytime I create a new project in IDEA 11, I have to open the inspection settings do disable the spellchecking and it is really annoying! At least make it configurable what the default setting is...


Regards,

BTJ

9 comments

Hello Bjørn,

If you don't check the "Share profile" checkbox in Settings | Inspections,
the inspections profile should be saved at application level and reused between
all of your projects.

We don't have any plans to disable the spellchecker by default.

Everytime I create a new project in IDEA 11, I have to open the
inspection settings do disable the spellchecking and it is really
annoying! At least make it configurable what the default setting is...


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

If disabling Share profile" does the trick, it's good enough for me... :)

I have never understood the reason for having a spell checker at all in IDEA (it's just annoying...) but that's a different discussion...


BTJ

0

Hello Bjørn,

The spellchecker has helped us find a ton of typos both in our method names
and javadoc comments. We definitely find it useful.

I have never understood the reason for having a spell checker at all
in IDEA (it's just annoying...) but that's a different discussion...


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

In general I like the spell checker because I too have found typos in my method names, comments, and JavaDocs; however, on rare occasions I found it annoying because it can add a lot of noise to the right hand side gutter. This becomes a problem when I am using shift-F7 to find usages and the usage marks are hidden in a bunch of invalid marks from the spell checker (abbreviations and such) I know I can put these abbreviations in my dictionary but it can become tedious since code tends to have a lot of them).

0

Hello Michael,

Ít's supposed to be possible to turn off the error stripe marks produced
by the spellchecker inspection while leaving the rest of the inspection enabled.
Right now this doesn't seem to work, which seems to be a bug.

In general I like the spell checker because I too have found typos in
my method names, comments, and JavaDocs; however, on rare occasions I
found it annoying because it can add a lot of noise to the right hand
side gutter. This becomes a problem when I am using shift-F7 to find
usages and the usage marks are hidden in a bunch of invalid marks from
the spell checker (abbreviations and such) I know I can put these
abbreviations in my dictionary but it can become tedious since code
tends to have a lot of them).


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Do you need me to open a youtrack issue for this? :-)

0

Hello Michael,

Do you need me to open a youtrack issue for this? :)


I would appeciate it. Thanks. :)

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

We have everything except class and method names in German. That is, all comments, strings and even variable names are in a language the spell checker doesn't understand. The first thing I do is turn it off for all new IDEA installations.

Is there a good place to download additional .dic files in good quality for other languages than English?

Thanks,
Dirk

0

Hi Dirk,

Please check this thread for information about how to configure german dictionary.

Regards, Denis

0

Please sign in to leave a comment.