Space and indentation created on 'save' (corrupts change diff in version history)

New to IntelliJ.

For a single line of change in the pom file, IDEA changes the whitespaces characters, which results in showing a large amount of "diff history" in version control.

Where can I turn this setting off?

I unchecked, Editor->Strip trailing spaces, still not change.

5 comments
Comment actions Permalink

Hello infinity,

Please make sure that the "Before commit | Reformat code" checkbox is unchecked
in the Commit Changes dialog.

For a single line of change in the pom file, IDEA changes the
whitespaces characters, which results in showing a large amount of
"diff history" in version control.

Where can I turn this setting off?

I unchecked, Editor->Strip trailing spaces, still not change.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I use git via cmd line and the reformatting still occurs.

0
Comment actions Permalink

Hello,

Please provide the following information:

  • actual change details ('before' and 'after' files);
  • when do you see that huge change - after 'commit', 'push', something else?


Denis

0
Comment actions Permalink

- the changes are random, as in it replaces blocks of text in pom.xml with the *SAME* content. i suspect there are empty charactetrs at the end of each line that it's trying to strip down.

This happens at each git commit.

0
Comment actions Permalink

Blocks of the same content are not considered to be different by vcs. Please provide exact 'before' and 'after' files in order to check what is the exact difference.

Denis

0

Please sign in to leave a comment.