How to disable ""This file is indended with.." inspection message?

Hello,

Does anyone know how to disable the message that pops up such as "This file is indented with tabs instead of 4 spaces"? When I click on the 'show settings' link,  under Code Style I see that 'Detect and use existing file indents for editing' is checked, and I really like this feature. Then under 'Inspections' settings, I see a listing called General -> Problematic whitespace, which seems like it should be the one responsible however it is unchecked and the message continues to pop up whenever I open a source code file that isn't in the 'preferred' format.

I'm seeing this in Webstorm 10.0.4, however I figured it was a general IntelliJ feature so thought it best to ask here.

Thanks,
Rich

4 comments
Comment actions Permalink

Disable "Detect and use existing file indents for editing":

http://i.imgur.com/xkDnLGj.png

There is no way to disable the warning without disabling this option.

0
Comment actions Permalink

serge wrote:

Disable "Detect and use existing file indents for editing":

http://i.imgur.com/xkDnLGj.png

There is no way to disable the warning without disabling this option.


Doesn't this mean that it will use the spacing options set in the 'Code Style' preferences rather than what the file is already formatted with?

Ideally, I would like it so that if I create a new file, it uses the whitespace settings from the IDE preferences, but when I edit an existing file it detects and uses whatever format the file is in (without warning me every time that the file is not formatted according to my 'preferred' settings).  Is this possible?

Thanks,
Rich

0
Comment actions Permalink

Submit a request at http://youtrack.jetbrains.com/issues/IDEA to disable the warning without disabling the feature.

0
Comment actions Permalink

Thanks, I've filed a feature request here: https://youtrack.jetbrains.com/issue/WEB-17383

Best,
Rich

0

Please sign in to leave a comment.