How do I override project javascript settings?

I pulled a sailsjs project from git and make a intellij project over the source files. It decided that my js code should use 2 spaces as tab. I want it to used a 4 spaced tab character.

I tried changing the scheme to my custom one, copying the cutom scheme over project, and using the custom scheme directly. For some reason, the sample code always shows 2 spaces as tab.

How can I change it?
2 comments
Comment actions Permalink

Double check your code style scheme specifies 2 spaces for JavaScript, attach a screenshot with the code style to confirm.

Do you have .editorconfig file anywhere in your project? Try disabling editorconfig support in Settings/Editor/Code Style by unchecking 'Enable Editorconfig support' checkbox - does it make any difference?

0
Comment actions Permalink

Disabling editorconfig fixed it.

Thanks!

0

Please sign in to leave a comment.