6 comments
Comment actions Permalink

(1) Open: File > Export Settings...
(2) Uncheck everything, but "Code style" and hit "OK".

0
Comment actions Permalink

Thanks. I don't have 'code style' as amongs the options, I had tried doing that. I will attach a screenshot. The closest thing I can see is 'code folding', whatever that means.



Attachment(s):
export.png
0
Comment actions Permalink

Hmmm... I have different set of exportable settings. I use version 14.1.4, but I think "Export Settings" feature has been there since at least 13.x.
One thing I've noticed is my list has significantly more entries - do you use Ultimate or Community edition (got Ultimate myself)? If you have Community, it may be "Export Settings" limitation (though it would be odd) or just plain bug.



Attachment(s):
Export Settings.png
0
Comment actions Permalink

I'm actually using Ultimate myself... I have no IDEA why I have fewer settings. The only thing I see is you are using Windows an I'm on a Mac. Actually, this could be answered by a jetbrains person.

0
Comment actions Permalink

I'm pretty sure "Export Settings" on my Mac looks the same as on Windows. Will check that later, when I get back home.

0
Comment actions Permalink

Checked "Export Settings..." on my Mac - I got "Code style" on the list, so it seems like it is either a bug or broken installation/settings on your Mac. Either way, you need somebody from JetBrains/IDEA team to help you fix the problem. You can try to reinstall IDEA, but most likely you need to wipe out the settings to get truly "fresh" installation, which means configuring everything from scratch.

0

Please sign in to leave a comment.