Opening Eclipse project doesn't work

I tried opening up an existing Eclipse project that my group is using (I'm on the only IDEA user) and IDEA appeared to be scanning the Eclipse project but then did nothing. There is no errors or exceptions and there is no project opened.
I know the Eclipse project is valid since it is submitted to the repository and everyone else in the group here uses it.

I then tried to import the project and it appeared to recognize all the modules, the problem is though that the dependencies are not resolved correctly and neither are all the facets detected correctly. Since there are many modules having to go through the process of resolving everything manually for every new branch I work on will be too painful. I'm sad to say if IDEA can't recognize Eclipse projects correctly I will need to switch to Eclipse.

1 comment
Comment actions Permalink

Hello Samuel,

any details on the project you are using? Import works fine for me here for simple java project. IDEA doen't recognise MyEclipse, etc settings though ... Is it possible to attach your project structure with .project/.classpath files?

Thank you


Please sign in to leave a comment.