Latest builds error when setting -Xmx1024m in idea.exe.vmoptions

Latest builds error when setting -Xmx1024m in idea.exe.vmoptions but -Xmx768m  works just fine, am I missing something   

6 comments
Comment actions Permalink

What's the exact error?
If you're on Win32, the JVM might not be able to allocate a large enough continuous memory block due to libraries loaded at specific addresses.

0
Comment actions Permalink

In addition, 1024m is a big high, even for large projects.

Note that IntelliJ uses memory mapping for accessing the large index
structures on disk.

Configuring a large heap might actually hurt performance, since full GC
sweeps will take longer.

-tt

0
Comment actions Permalink

TarasT wrote:

In addition, 1024m is a big high, even for large projects.

Note that IntelliJ uses memory mapping for accessing the large index
structures on disk.

Configuring a large heap might actually hurt performance, since full GC
sweeps will take longer.

-tt



If you use the analysis features line Analyse->Inspect Code, memory is a problem.  IDEA runs out of memory if I try to run too many inspections across my project.  I have to limit the scope or limit what inspections I run. The inspections themselves are using some memory, plus the 1000s of items found take up memory.

These are the settings I am currently using for Maia EAP on Ubuntu 9.04.  I recommend using the  UseCompressedOoops as it helps cut down on memory usage by 30-40%. But you need to use JDK 6 update 16 or newer. I am using JDK 6 update 18 ea 4 (https://jdk6.dev.java.net/6uNea.html)

-Xms256m
-Xmx1292m
-XX:MaxPermSize=190m
-XX:+UseCompressedOops

Performance is super fast on quad core i7 workstation, esp. for IDEA features which fully utilize all the cores.

-Alex

0
Comment actions Permalink

Geez, sounds awesome!
I wish this JDK6 update were available on OsX...

I use -Xmx1024m on 10.6.2 and it works fine.

On 2009-11-12 09:29:09 +0900, Alex   <no_reply@jetbrains.com> said:

TarasT wrote:
>
> In addition, 1024m is a big high, even for large projects.
>
> Note that IntelliJ uses memory mapping for accessing the large index
> structures on disk.
>
> Configuring a large heap might actually hurt performance, since full GC
> sweeps will take longer.
>
> -tt
>



If you use the analysis features line Analyse->Inspect Code, memory is
a problem.  IDEA runs out of memory if I try to run too many
inspections across my project.  I have to limit the scope or limit what
inspections I run. The inspections themselves are using some memory,
plus the 1000s of items found take up memory.

These are the settings I am currently using for Maia EAP on Ubuntu
9.04.  I recommend using the  UseCompressedOoops as it helps cut down
on memory usage by 30-40%. But you need to use JDK 6 update 16 or
newer. I am using JDK 6 update 18 ea 4
(https://jdk6.dev.java.net/6uNea.html)

-Xms256m
-Xmx1292m
-XX:MaxPermSize=190m
-XX:+UseCompressedOops

Performance is super fast on quad core i7 workstation, esp. for IDEA
features which fully utilize all the cores.

-Alex

---
Original message URL: http://www.jetbrains.net/devnet/message/5249789#5249789



0
Comment actions Permalink

Tried to enable UseCompressedOops but I just got an error telling me: "Unrecognized VM option '+UseCompressedOops'"

Are you sure that it is included in update 16? I am running JDK 1.6.0_17...


Edit: Never mind... Found out that this parameter only works in 64 bits JDK...


BTJ

0

Please sign in to leave a comment.