Strange VCS gutter colours/behaviour in IDEA 10

Since moving to IDEA 10 I've noticed that the VCS colouring for sections
of code in the left hand gutter have changed.  I've been all through the
Colour settings but I can't see where the colours are defined so I can
change them back.  I used to get blue for modified code, green for added
code, and a red mark for deleted code.  Now I just get this dark purple
colour.

Not only that, but the highlighting seems to appear and disappear when I
move through the code, disappearing, changing to grey and reappearing
again. :-S

On top of this, the vcs gutter markers seem to have disappeared from the
right gutter completely.

I've uploaded a screen cam that shows the symptoms :
http://www.youtube.com/watch?v=349u95O7f9Q

Is this expected behaviour or some new feature/setting I'm not aware of?

Thanks for any info!
N.

2 comments
Comment actions Permalink

OK, maybe I should have looked in YouTrack first... but it seems that,
according to http://youtrack.jetbrains.net/issue/IDEA-62208 the problem
was that the color setting for the stripe in the "Editor" -> "Colors &
Fonts" -> "Diff" was corrupted in some way, it just showed black.

Resetting them to the proper colours seems to make both gutters work
again nicely!  I've just been using the same scheme all these years so
it seems that there is a migration issue between 9 & 10 you might want
to address.

On 10/12/2010 3:03 PM, Nathan Brown wrote:

Since moving to IDEA 10 I've noticed that the VCS colouring for sections
of code in the left hand gutter have changed. I've been all through the
Colour settings but I can't see where the colours are defined so I can
change them back. I used to get blue for modified code, green for added
code, and a red mark for deleted code. Now I just get this dark purple
colour.

>

Not only that, but the highlighting seems to appear and disappear when I
move through the code, disappearing, changing to grey and reappearing
again. :-S

>

On top of this, the vcs gutter markers seem to have disappeared from the
right gutter completely.

>

I've uploaded a screen cam that shows the symptoms :
http://www.youtube.com/watch?v=349u95O7f9Q

>

Is this expected behaviour or some new feature/setting I'm not aware of?

>

Thanks for any info!
N.


0
Comment actions Permalink

OK, maybe I should have looked in YouTrack first... but it seems that,
according to http://youtrack.jetbrains.net/issue/IDEA-62208 the problem
was that the color setting for the stripe in the "Editor" -> "Colors &
Fonts" -> "Diff" was corrupted in some way, it just showed black.

Resetting them to the proper colours seems to make both gutters work
again nicely!  I've just been using the same scheme all these years so
it seems that there is a migration issue between 9 & 10 you might want
to address.

On 10/12/2010 3:03 PM, Nathan Brown wrote:

Since moving to IDEA 10 I've noticed that the VCS colouring for sections
of code in the left hand gutter have changed. I've been all through the
Colour settings but I can't see where the colours are defined so I can
change them back. I used to get blue for modified code, green for added
code, and a red mark for deleted code. Now I just get this dark purple
colour.

>

Not only that, but the highlighting seems to appear and disappear when I
move through the code, disappearing, changing to grey and reappearing
again. :-S

>

On top of this, the vcs gutter markers seem to have disappeared from the
right gutter completely.

>

I've uploaded a screen cam that shows the symptoms :
http://www.youtube.com/watch?v=349u95O7f9Q

>

Is this expected behaviour or some new feature/setting I'm not aware of?

>

Thanks for any info!
N.


0

Please sign in to leave a comment.