I need help with render library...

Hi everyone, and thank you for willing to help. Searched everywhere for this and can't find a solution for intellij so I decided to ask for help here.
So here's the error message whenever I open the Design xml: "This version of the rendering library is more recent than your version of IntelliJ IDEA. Please update IntelliJ IDEA (Details)". I have the latest IntelliJ and the error appeared after I installed some new versions of Android SDK Build-Tools with SDK Manager. I tried removing all the new versions of that but the problem remains. I found a solution for Android Studio where you force the ide to use a specific SDK Build-Tools version, but can't find how to do that on IntelliJ. Any help would be appreciated and please keep in mind that I'm a noob, have patience with me :D Also, sorry for my English...

Here are the Details, next to the error:
org.jetbrains.android.uipreview.RenderingException: This version of the rendering library is more recent than your version of IntelliJ IDEA. Please update IntelliJ IDEA
 at org.jetbrains.android.uipreview.LayoutLibraryLoader.load(LayoutLibraryLoader.java:90)
 at org.jetbrains.android.sdk.AndroidTargetData.getLayoutLibrary(AndroidTargetData.java:159)
 at com.android.tools.idea.rendering.RenderService.create(RenderService.java:198)
 at com.intellij.android.designer.designSurface.AndroidDesignerEditorPanel$6.run(AndroidDesignerEditorPanel.java:475)
 at com.intellij.util.ui.update.MergingUpdateQueue.execute(MergingUpdateQueue.java:320)
 at com.intellij.util.ui.update.MergingUpdateQueue.execute(MergingUpdateQueue.java:310)
 at com.intellij.util.ui.update.MergingUpdateQueue$2.run(MergingUpdateQueue.java:254)
 at com.intellij.util.ui.update.MergingUpdateQueue.flush(MergingUpdateQueue.java:269)
 at com.intellij.util.ui.update.MergingUpdateQueue.flush(MergingUpdateQueue.java:227)
 at com.intellij.util.ui.update.MergingUpdateQueue.run(MergingUpdateQueue.java:217)
 at com.intellij.util.concurrency.QueueProcessor.runSafely(QueueProcessor.java:238)
 at com.intellij.util.Alarm$Request$1.run(Alarm.java:351)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
 at java.util.concurrent.FutureTask.run(FutureTask.java:266)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
 at java.lang.Thread.run(Thread.java:745)

4 comments
Comment actions Permalink

Please attach a screenshot from Android SDK Manager showing which build tool versions are installed.

What Android platform version do you target in your app?

0
Comment actions Permalink

Here's the SDK Manager screenshot: http://gyazo.com/2c4a88fced050a3fd0d7ab143b400674
Not so sure about the targeted version, is it in the AndroidManifest? http://gyazo.com/162a0edfeed453ff90d45683af37add9 or is it in project.properties? http://gyazo.com/18a84e23f87edc6bf0a9f2db3e5d6203

0
Comment actions Permalink

I've asked the responsible developer to look into it. The issue is already logged at https://youtrack.jetbrains.com/issue/IDEA-141233 .

0
Comment actions Permalink

So this means they're working already to fix the issue? Any idea how long will it take? Also thank you for your time :D

0

Please sign in to leave a comment.