Java Code Format "Align 'throws' to method start" broken in 14.1.3?

Wondering if this is bug or it's just my install, but Editor -> Code Style -> Java -> Wrapping and Braces -> Throws list -> Align 'throws' to method start cannot be turned off.  With the box checked throws are aligned to the method start, and with the box unchecked throws are still aligned to method start.  I upgrade from version 13.1.6, and in that version the setting worked correctly.  I want the value unchecked - i.e. I want wrapped 'throws' statement to have an extra level of indentation.  But as it is now I do not get the extra indentation regardless of the value in settings.  Is anyone else seeing this?  I'm using tabs (not spaces) with smart tabs turned on, although changing to spaces didn't fix the problem either.

Thanks.

3 comments
Comment actions Permalink

Turned out there was a .editorconfig file in the root directory with "indent_size = 4" in it, and this screwed up the alignment.  Removing that line from the .editorconfig fixed the problem.

0
Comment actions Permalink

Thanks for the information.

You can also disable it in IDE settings:

http://i.imgur.com/g0ZRabt.png

0

Please sign in to leave a comment.