IDEA breakpoints in GWT using Grails and Super Dev Mode

My set up is:

Ubuntu 14.04
IntelliJ Idea 14.1.3
GWT 2.7
Chrome 43.0.2357.81
JetBrains IDE Support 2.0.8

I'm trying to debug the client side of a Grails application in IDEA. Since I need the compiled GWT code to load from the web-app directory of the grails app I set the -war option on the Dev mode parameters dialog to point to a sub-directory (which doesn't seem to do anything in the IntelliJ context). I also have a artifact to copy the results of the complie to the grails project web-app directory.  I start grails using Tools->Grails-Run target->run-app. Then I run the debug GWT configuration to start the GWT code server. Evenything seems to work just fine. The browser window comes up with the yellow JetBrains banner, the consoles show the codeserver starting and IDEA says it's connected to Chrome. The gray panel comes over the browser window while the code compiles, then the application starts running in the browser. Everything looks great.

But, as the application runs it does not stop at any breakpoints set in the client code in IDEA.

I can post more details, but at this point I'm not sure what would be helpful.

Thanks,

Roland

3 comments
Comment actions Permalink

I was just about to ask the same question (+GWT +"super dev mode" -Grails). I am using Chrome and can see the sourcemaps generated by the code server inside Chrome. I can set breakpoints in Chromes sourcemaps and those work. The Jetbrains Chrome plugin reports that is connected to Intellij. I can see console logging inside of Intellij. *But* breakpoints in Intellij are ignored (I set breakpoints in the client side Java code).

0
Comment actions Permalink

Also in console in Intellij when I click on a log row (e.g    Hello      xyz.js:789 ) it shows me the "obfuscated" javascripts. I would exepct that the source maps would be used to find the "real" source?

0
Comment actions Permalink

Seems as though is is a known issue with the latest version of Chrome: https://youtrack.jetbrains.com/issue/IDEA-139739

Apparently the options to workaround are to downgrade Chrome to 42, get the ItelliJ IDEA pre-release when the fix is ready or set the breakpoints in the Java source code representation in Chrome itself.

Roland

0

Please sign in to leave a comment.