Idea Community (including EAP 96.1190) slow typing

I tried finding existing threads on this, without much luck.

I am experiencing that IdeaIC (built from Git, and I tried downloading the 96.1190 Community EAP just for comparison) is slow to type in the Java editor. That is, I can out-type the editor, and I am not a speedy typist.

My question is two-fold:

1. Is anyone else experiencing this, or is it something unique to my setup?

2. What is an effective diagnostic technique for tracking down what might be causing such a delay?

I am on JDK 1.6.0_21 32-bit (and have tried 64-bit), Win7/Enterprise/x64, Dell E6500 8GB RAM, Intel X-80 SSD.

  Thanks in advance for your help,
  -- /v\atthew


Hi Matthew,

Right way is to make a performance snapshot and submit it to JB for analysis.

Regards, Denis


Thank you for your speedy response.

Adding the -agentlib:yjpagent to idea.exe.vmoptions yields:

Error occurred during initialization of VM
Could not find agent library on the library path or in the local directory: yjpagent

Which I suspect is because YJP is only included in the Ultimate (or perhaps formal) release of Idea.

Are there open source profilers you recommend, or is there a way I can obtain the YJP agentlib?

I have boosted the memory allocated to Idea up as high as my 32-bit VM will accept, and it does not appear to be even remotely taxing the upper bound (according to the memory monitor in the corner, who says "133M of 966M").

However, according to Process Explorer v12.04, while typing the Idea java.exe process goes up to 25% CPU usage.

  -- /v\atthew


You can download yjp agent library from their site then.

The document mentioned above contains instructions on how to perform configuration in that case (starting from 'Note that yjpagent library provided with IDEA will not work on 64-bit operating system when you run IDEA under 64-bit JVM...').

Regards, Denis


Yes, I saw the 64-bit OS warning, but I am running Idea under a 32-bit JVM. That was written in my initial problem report, and was repeated when I said I had maxed out the 32-bit process space.

I'll see what I can do about organizing a trial of YourKit, since I interpret your response to mean there are no other profilers available for this purpose.

  -- /v\atthew


I did not experience Start IDEA and you should notice 2 new buttons in the toolbar, one for taking CPU snapshot, another one for Memory snapshot. when I fired up Idea under the YourKit profiler.

However, YourKit was kind enough to save the snapshot after exiting. I uploaded "" as directed by the linked webpage.

That session consisted of:
1. Open Idea
2. Open the project
3. Typey-typey (enough to confirm the problem; only one line of Java)
4. Close Idea

  -- /v\atthew


I checked the snapshot and it doesn't show any problem. I.e. there is no excessive system resource consuming by any particular activity.

The only suspicious thing is that it shows that IDE startup was not finished, i.e. particular files were still being loaded from the disk (implying I/O processing).

Try to wait for the full IDE initialization (progress bar at the bottom of the window doesn't show that there are active background tasks). Also ensure that IJ processing is not affected by external conditions like system resources consumptions by another processes, anti-virus processing etc.

Regards, Denis


Please sign in to leave a comment.