Configuring indentation for SQL

When I type a query in the SQL console, IDEA applies the following formatting:

select *
  from SOME_TABLE c
  where c.ID = 12


The lines after the initial "select *" are indented.
Where can I disable this indentation?
2 comments

Hi.

Settings / Code Style / General / SQL / Indent subclauses.

Alexander.

0

Thanks, found it.

The new SQL console in IDEA 10 is actually quite nice, good work.
Implement smart completion (http://youtrack.jetbrains.net/issue/IDEA-19908), and it will become my primary database query tool soon. :)

0

Please sign in to leave a comment.