IDEA Ultimate 14.1 : Unable to debug XSLTs

I previously used that feature (long ago, on IDEA 12 or before I guess).

I jsut tried it and debugger fails to start with the following errror

Connecting to XSLT runner on localhost/
Warning: external object model net.sf.saxon.dom.DOMEnvelope has been loaded, but is not an instance of
Warning: external object model net.sf.saxon.dom.DOMObjectModel has been loaded, but is not an instance of
Exception in thread "main" java.lang.IllegalArgumentException: TRACE_LISTENER is of wrong class
 at net.sf.saxon.Configuration.setConfigurationProperty(
 at net.sf.saxon.TransformerFactoryImpl.setAttribute(
 at org.intellij.plugins.xsltDebugger.rt.engine.local.saxon9.Saxon9Support.createTransformerFactory(
 at org.intellij.plugins.xsltDebugger.rt.XSLTDebuggerMain.createTransformerFactory(

I checked the non Jetbrains plugins, and couldn't find any saxon classes in them

Indeed ... didnt think it would look for saxon in my own projetct's classapth.
I fixed it by changing the "use JDK/classpath from  module"  from advanced properties, and just point to IDEA SDK.

Thanks !


Please sign in to leave a comment.