Cannot connect to jira, please enter captcha in web interface?

I keep getting these popups every time I try to create tasks in IDEA ultimate, my server settings are correct and I've authenicated against the captcha in firefox (OS default browser) but I still get these messages. Does it means some other web interface?

This is on IDEA 14.1.2 on Centos 6.3.

5 comments
Comment actions Permalink

Hi Richard.

Did it happen in previous version of IntelliJ IDEA?  What version of JIRA do you use (most importantly, is it JIRA OnDemand)?
To be honest, I had several requests that the current version of JIRA integration causes logouts in browser (it may be related), but I didn't succeed to reproduce them so far.

Could you please do the following

  • remove existing JIRA connector or create new project
  • authorize in the web-interface of your JIRA instance if you didn't
  • restart IDE
  • enable logging categories httpclient.wire.header and #com.intellij.tasks, e.g. via Help | Configure Debug Log Settings
  • set up JIRA connector anew and attempt to fetch issues several times (so messages about CAPTCHA appear)
  • attach recorded idea.log file here


Also please notice that there will be some sensitive information in such log, in particular "Authorization" header, so you may want to edit it a bit before posting.

0
Comment actions Permalink

I don't know about eariler versions of IDEA, not because I didn't use it, but the captcha is a new addtion to our JIRA, which is v5.1.7.
In the past the IDEA (sans captcha) JIRA auth used to timeout regularly but would work evenually on repeated attempts.

I'll try the capturing later, by JIRA connector I guess you mean the JIRA server settings - I don't use the atlassian plugin.

Also by web interface you mean the default OS browser?

0
Comment actions Permalink

by JIRA connector I guess you mean the JIRA server settings - I don't use the atlassian plugin.

Yes, I mean task server settings in the IDE. I just don't want to cause any confusion because it's actually a client ;)

Also by web interface you mean the default OS browser?


I mean any browser. JIRA can ask you to enter captcha in its web-interface after several unsuccessful login attempts.
We don't interact with any specific browser for this integration, it's solely to make JIRA allow you authenticate youself for further REST API requests.

I'll try the capturing later

Thank you, I'm looking forward to it

0
Comment actions Permalink

Ah well I got as far as restarting IDEA and suddenly its working. Our JIRA requires the captcha for every session. But what seems to work is starting firefox, logging into JIRA with the captcha then start-up IDEA. I'd guess the JIRA Connector will keep working while this session remains good. Normally have to reenter it a couple of times a day. So if it stops repeat the above.

I think thats what did it. I also had a tinker with the browser prefs, I moved firefox up to the top of the list of browsers and toggled the default browser from system to first then back to system again. I think it was the restart after firefox auth that worked.

0
Comment actions Permalink

I just got bitten by this and I think I've worked out what was going on. My previous JIRA password (saved in PHPStorm) had expired. PHPStorm's login attempts triggered JIRA to request a captcha on next login. However my browser already had an active JIRA session and as a result I didn't get presented with the captcha as I didn't need to sign in. The solution was to log out of JIRA in my browser and log in again.

0

Please sign in to leave a comment.