use xmodmap set up/down arrow,but no valid in tool windows of intellij idea

i use intellij idea in ubuntu , intellij idea's keymap  up and down  no effect in tool windows , so  i use xmodmap set up/down arrow to ctrl+jk, in editor is valid,but project of tool windows navigation no valid.help me . i donnot think use mouse navigate it.  

6 comments

Sorry, what's the problem with Up/Down keys in tool windows?

0

i mean that : i hope use ctrl+jk control  up/down in tool windows(eg:project navigation). i hope not use mouse or up/down control,because mouse make hand leave keybord,and up/down so far.

0

I think I have a similar problem with IntelliJ+~/.Xmodmap

Here is my ~/.Xmodmap:
keycode 66 = Mode_switch
keysym h = h H Left
keysym j = j J Down
keysym k = k K Up
keysym l = l L Right
keysym y = y Y BackSpace
keysym u = u U Next
keysym i = i I Prior
keysym o = o O Delete
keysym space = space space Return

Basically, that remaps CapsLock+hjkl to arrows

and CapsLock+yuio to Backspace, PageUp, PageDown, Delete
and CapsLock+Space to Return
.




Those remaps work fine in X, and in my various JNLP apps
.




But in IntelliJ, some of them fail to work
.



From my experience (IntelliJ 12.1.4 IU-129.713 Ubuntu 64bit 12.04), the working remaps are:
CapsLock+jk
CapsLock+ui




.
The failing remaps are:
CapsLock+hl
CapsLock+yo
CapsLock+Space




.
May be, you can investigate that point.
That is REALLY annoying me.
0

I got nearly the same setup like you on Ubuntu 14.04.
My .Xmodmap file looks like this:

! Disable Caps Lock and use it as mode switch
keycode 66 = Mode_switch Mode_switch


! Toggle Caps Lock with <Mode_switch> + <Control_R>
keysym Control_R = Control_R Control_R Caps_Lock


! Remap navigation block to ijkl...
keysym j = j J Left Left
keysym l = l L Right Right
keysym i = i I Up Up
keysym k = k K Down Down
keysym u = u U Home Home
keysym o = o O End End


! ö Ö
keycode 47 = odiaeresis Odiaeresis BackSpace BackSpace


keysym h = h H Delete Delete
keysym n = n N Prior Prior
keysym m = m M Next Next mu mu


! Space to Escape
keysym space = space space Escape


The awkward thing is, that this remap acts everywhere as expected in my Ubuntu desktop, except this editor.
All the keys don't do anything, except the Up and Down keys I and J. But here it acts, as if I would press Ctrl simultaniously and the page ist scrolling, rather than the cursor.
Has anyone found a solution for this problem yet?
Please, this really bothers me. Like this way, I cannot enjoy this editor...

0

Same problem here, I have alt and windows key swapped because of weird keyboard, and in intellij I have to press both keys for it to notice the alt... Any help would be appreciated.

0

Please sign in to leave a comment.