YourKit Error on Ubuntu with JDK 6u21 (thinks it is JDK 7)

ccanning@ccanning:~/intellij/idea9.x/bin$ ./idea.sh
YourKit Java Profiler 8.0.22 cannot start: latest Java 7 builds cannot  be profiled anymore with this version of the profiler. To profile with  Java 7, use YourKit Java Profiler 9.0 - http://www.yourkit.com/eap

ccanning@ccanning:~/intellij/idea9.x/bin$ $IDEA_JDK/bin/java -version
java version "1.6.0_21"
Java(TM) SE Runtime Environment (build 1.6.0_21-b06)
Java HotSpot(TM) 64-Bit Server VM (build 17.0-b16, mixed mode)

4 comments
Comment actions Permalink

You can disable the yourkit  integration by removing the followig line from idea.exe.vmoptions file.

-agentlib:yjpagent=disablej2ee,disablecounts,disablealloc,sessionname=IntelliJIdea90

To fix the  problem, you probably need to download a newer version of the yourkit  yjpagent.dll file from yourkit.com

-Alex

0
Comment actions Permalink

Yeah, I have disabled it. i was just making you aware of the issue. Is IDEA compatible with the latest EAP? I also posted to the YourKit forum too.

0
Comment actions Permalink

The YourKit people have acknowledged this is a bug and expect to have a new version of 8.0.x out in a few days. can we expect it to be bundled with the next EAP?

http://forums.yourkit.com/viewtopic.php?f=3&t=3390#p11251

0
Comment actions Permalink

Yes it will be included, but since it's just a bugfix release you can update it by yourself - just download new YourKit (8.0.26) and update agent binary in idea/bin/ and controller API .jar in idea/lib/.

0

Please sign in to leave a comment.