Anti-alias

Hi, I'm using Idea under 64-bit Ubuntu.  For some reason even though I have anti-alias checked in the settings the fonts in the editor aren't anti-aliased.  Is there a trick to get this working?

Regards,

Glen

9 comments
Comment actions Permalink

Hi Glen,

Antialiasing at editor works fine for me under Ubuntu 9.10, sun jdk 1.6.0_19 64 bit. Please provide more information about your environment.

Regards, Denis

0
Comment actions Permalink

I'm running Ubuntu 10.04 with gnome and compviz.  I'm running 9.0.2 build IU-95.66.

java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)


Interestingly some of the text in the IDE does appear antialiased:

screenshot1.png

Is there any more info you require?
0
Comment actions Permalink

That's strange. Please try to reopen your project (close it via 'File -> Close Project' and open via 'File -> Open Project').

0
Comment actions Permalink

I've tried that several times (and did it again just to be sure).  It did not help unfortunately.

0
Comment actions Permalink

glens wrote:

I've tried that several times (and did it again just to be sure).  It did not help unfortunately.

Thanks, I asked our GUI guys to help with that.

0
Comment actions Permalink

We tried to reproduce the problem at local environment but with no luck.

Can you check if it helps if you define default font for the editor and reopen a project?

0
Comment actions Permalink

Thanks Denis,

I've tried that but unfortunately no luck.  I also deleted my entire configuration directory to see if that worked but also no joy.

-- Glen

0
Comment actions Permalink

Good news - I've figured it out.  In idea.properties I had the following:

idea.use.default.antialiasing.in.editor=true

changing this to false fixed the editor anti-aliasing.  I'm not sure at what point this got set to true but it seems to be the cause of my problem.  Interestingly my system has antialiasing on by default so I would have expected it to use the system default however it failed to pickup the default settings.

Thanks very much for your help in trying to resolve this problem for me.

-- Glen

0
Comment actions Permalink

Excellent!

Thanks for the information, we'll analyze it.

0

Please sign in to leave a comment.