EAP and non EAP versions together (OS X)

I'm working with the EAP version primarily because the latest Scala plug-ins need it.  Unfortunately, that means my "official release" version on longer loads.  Is there anyway for the EAP and it's plugins/configurations to not interfere with the "official release" version? This way, in the event of a catostrophic failure in a plugin (or EAP), I'm not forced to reinstall EVERYTHING?

David

3 comments
Comment actions Permalink

Hello david,

I'm working with the EAP version primarily because the latest Scala
plug-ins need it.  Unfortunately, that means my "official release"
version on longer loads.  Is there anyway for the EAP and it's
plugins/configurations to not interfere with the "official release"
version? This way, in the event of a catostrophic failure in a plugin
(or EAP), I'm not forced to reinstall EVERYTHING?


You can edit the Info.plist file inside the IntelliJ IDEA package directory
and specify different values of idea.config.path, idea.system.path and idea.plugins.path
for EAP and non-EAP versions.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Does the info.plist only apply to Mac OS?

0
Comment actions Permalink

if you start idea using the os x equvalent of idea.bat, you can specify which idea.properties should be used which in turn defines the paths where idea should store its caches

0

Please sign in to leave a comment.