95.214 U keeps crashing with multiple projects loaded

The 95.214 U build seems to keep crashing on me when I have multiple projects loaded. I will attach the dump files. This is on ubuntu 8.04LTS and Sun JDK 1.6.0_20x64 with the following settings.

-Xms128m
-Xmx384m
-XX:MaxPermSize=192m
-XX:+UseCompressedOops
-XX:-EliminateLocks
-XX:+UseBiasedLocking
-ea



Attachment(s):
hs_err_pid29220.log.zip
hs_err_pid11465.log.zip
hs_err_pid10294.log.zip
7 comments
Comment actions Permalink

why
-XX:+UseCompressedOops
-XX:-EliminateLocks
-XX:+UseBiasedLocking
?

0
Comment actions Permalink

After testing the JVM settings, these give me the best performance in both memeory and speed. The improvement can be significant with an almost 1.5X savings in memory and up to 30% speed improvement.

0
Comment actions Permalink

Just an FYI, I have been using these settings since they have been supported in the Sun JDK 1.6.0_14.

0
Comment actions Permalink

i've been aiming at the fact that they don't make sense. the speed difference of idea won't even be measureable. and, if you're going for performance, you'll want to use the "-server" option, which has a really high impact., sometimes 50% or more.
also, using compressed ops only makes sense when using a 64 bit vm, which only makes sense if you need several gigabyte of memory, but your Xmx option is at 384.

but i cannot help you, sorry.

0
Comment actions Permalink

Hi,

You should have put Ubuntu 8.10 x64 in your title - I almost didn't look at this..

Looking at the fatatl error you are getting:

#  Internal Error (nmethod.cpp:1836), pid=29220, tid=1142454608
#  Error: guarantee(cont_offset != 0,"unhandled implicit exception in compiled code")


I have gotten this same exception. The following is copied from previous thread where I posted some info http://www.jetbrains.net/devnet/message/5259840#5259840

From the JVM fatal error, it looks like a hotspot JIT error, so I added -Djava.compiler=NONE in idea.vmoptions and restarted again.
That made the problem go away, but IDEA is too slow to use.  It took about 30 minutes for it to rebuild my cache.

I don't think IDEA has any bug, but each new version has different code, and it looks like the latest IDEA code is exposing a bug in the linux hotspot JIT.
When 9.0.2 is released, I'll try again. Maybe the problem will go away on it's own.  I did file a bug with Sun, but who knows when or if they will look into it.

For development work, I've been forced to go back to Windows 7 64-bit platform which is working fine so far.


So, I have continued using Windows 7 64-bit since I have not found a solution to the issue and there is no workaround except turning off the JIT which kills the performance.

-Alex

0
Comment actions Permalink

Thanks for the info. It seems to be intermittent as I have had 2-3 projects running all day today.

0
Comment actions Permalink

The default for my JVM is -server. I find the memory management to be more stable with the 64-bit JVM, especially when I have to increase memory. Depending on which projects I am running, I sometimes have to increase it to a few Gb. You are right that I will probably not notice much of a performance improvement with Idea, but I haven't seen any negative side effects.

0

Please sign in to leave a comment.