Disable highlighting in fxml code

Hello,

i have for example a button in my fxml file with a onAction event but no controller assigned inside the fxml.
because of that, IntelliJ IDEA colors the onActions red and gives me a lot of errors when i commit my code or in other situations (codeanalysis...)

how can i disable the coloring and turn off the errors


Thanks a lot



Attachment(s):
example.png
6 comments
Comment actions Permalink

Hello,

nothing new for me, but didn't help, i set the highlighting level to "None". The onActions still colored red and when i do a code analyzis i still got the error "No controller specified for top level element (at line X) "
to get rid of this error message i disabled "General | XML highlighting". but inside my code, the onAction is still red. i can live with that, but would like to see it not red.
 
 
 

0
Comment actions Permalink

i was changing the fonts and found the option.
in settings under Editor->Colors & Fonts->General i had to change the "Unkown symbol" color.
but because its not bind to the fxml file i don't change the color

thx so far

0
Comment actions Permalink

Actually it looks like a bug to me. Will investigate. Thanks

0
Comment actions Permalink

Hector works but you need to close/open the file. Submitted as https://youtrack.jetbrains.com/issue/IDEA-138901.

0
Comment actions Permalink

i need to close the complete IDE under Linux and reopen it, then it works after setting Hector to "None"

0

Please sign in to leave a comment.