Missing version control entries in Repository tab of Changes panel

I am using CVS as my VCS. Several change entries that should be listed in the Repository tab are missing. If I look at the CVS->Show History for a specific file, the change is listed. However, the same change does not appear in the Changes->Repository list.

Things I have tried:

  • Updated my project with the latest revisions from my source repository multiple times.
  • Deleted and regenerated my caches including vcsCache multiple times.
  • Re-installed IDEA.
  • Deleted my .iws file and let IDEA re-create a new one.


Using WireShark to monitor network traffic, I can see that the missing changes are being retrieved from the CVS server (I'm using pserver) in response to IDEA's rlog command when I click the Refresh button. I don't see any errors in the logs or in the command window where I launch IDEA. I verified that "Filter by" is set to "None".

I have two projects that are virutally identical except that one is from the head, and one from a branch of the source repository. The entries are missing in both.

I have not been able to identify any pattern for the missing entries. They are changes from different users, different dates, different files in different directories.

Also, I don't have any idea how many entries are missing. The only reason I noticed it at all was because a co-worker told me he checked-in some changes, yet they are not appearing in my list. I noticed the problem after installing IU-94.585. However, it could have been happening in previous releases and I just didn't notice.

Can anyone offer any advice as to what is going on? Any additional steps I can take to diagnose the problem?

Any help is greatly appreciated.

7 comments

I just verified that this is happening in the released 9.0.1 as well.

Disregard. I launched the wrong version for my test.

I verified that the problem does NOT happen in release 9.0.1.

0

Could you please describe how your VCS roots are configured.
We will try to check/reproduce the problem at our side.
Thank you

0

Attached are screenshots of my CVS roots configuration.

Also, IDEA is configured to cache 90 days of history and update every 30 minutes. Version 9.0.1 displays 1,630 changes in the Repository tab for the last 90 days. Version 94.585 displays only 453 for the same 90 day period.

Let me know if I can provide more info.

Thank you.



Attachment(s):
Clip2.png
Clip1.png
0

Yes, the symptoms I am observing match those in the bug.

Thanks.

0

I see that the problem still exists in 95.54. Is JetBrains planning to release 9.0.2 without fixing this issue? I am essentially stuck at 9.0.1 until this is fixed.

Thanks.

0

I used to find this problem when we were using CVS. For some reason, the Changes panel would not display my own recent changes in the Repository panel, although it would display other contributor's changes up to date. All the changes were visible when browsing the repository or in the file history. Every week or so, my changes would get updated. I could never find a way of manually getting them up to date (I tried refreshing, reloading IDEA, deleting caches, reconfiguring VCS, etc).

The problem went away when we changed to Subversion...

0

Please sign in to leave a comment.