Moved to Ubuntu/Linux: Idea can't resolve java.lang.String

Hi all,

I'm a longtime idea user.

I recently switched my laptop from windows to linux.

When opening my projects, the idea editor cannot resolve any 'java.lang.*' objects. Everything is highlighted red.

I've search the internet and tried the following:
-dropped and added jdk's, changed the jdk for the project, etc.
-confirmed rt
-cleared caches
-deleted the system folder
-switched jdk versions (I originally had started on IBM jdk and thought that was the problem)
-renamingmy Idea director (~/.IntellijIdea11)

I found that creating a new project (from scratch) succeeds (i.e. editor can resolve java.lang.String)..;just not old projects

I'm using Idea 11.17 on Ubuntu 14.04LTS

Any suggestions?



Comment actions Permalink

Check the module depednecies for the old projects, make sure they are set to use Project SDK and the Project SDK is set to the correct one.

Comment actions Permalink

That was it.

Bad module depdencies caused the problem--some modules pointed a no-longer existent JDK

Changing these modules to use 'project jdk' solved the problem.

Thanks Serge.


Please sign in to leave a comment.