Tab character as indent

I set preferencies as it shows on the picture but in the code indents are as 4 spaces.
As I can see, my changes for DEFAUL indents doesn't applies to the  different file types.
Is it bug or I always need to set needed preferenceis for all file type and default preferencies dosen't meen anything?



Attachment(s):
idea_indent_technologies.PNG
idea_indent.PNG
5 comments
Comment actions Permalink

Hello.

Please make sure that "Enable EditorConfig support" setting on the root Code Style page is Off.

Regards,
Alexander.

0
Comment actions Permalink

I have "Enable EditorConfig support" setting is off.
I've attach the scrinshot from another project where I need "spaces" instead of "tabs".
I marked the line where I pressed "Tab" two times. And shot result with code style settings window.



Attachment(s):
idea_indent_2.PNG
0
Comment actions Permalink

Yes, currently a setting for individual file types overrides the general one. I will ask the developer, is it going to be changed.

Regards,
Alexander.

0
Comment actions Permalink

Thanks.

Will hope, it will be changed soon, not in idea 15 :).
If you will create an issue in youtrack can you take link on it?

0
Comment actions Permalink

Developers have explained that "default" settings are applied to file types that have no specific sub-pages in the dialog. E.g. to plain text files. So, the meaning of this group of settings is "for all the rest, not listed file types".

With that I think YouTrack issue would be wrong.

Regards,
Alexander.

0

Please sign in to leave a comment.