IDEA very slow on Mac OS X

Anybody else experience that? Our project consist of around 400.000 lines of source code. It depends also on some big external libraries, like Oracle JDBC and JBuilder libraries (GUI and DX).

Editing of any file in this project is impossible on PowerBook 1.25Ghz, 2GB RAM. I enlarged heap to 512MB, but still too slow.

How slow? When I go to the end of the line and press enter, I need to wait around 10s. Then I type and after 20 characters, line gets updated. Code completition is also very slow.

Even cursor movement is slow. It takes seconds for each move.

I belive it is inspections which are so slow. I ran "Inspect Code" and it seems it took an hour before it displayed results. 30min for sure.

Is it possible to reduce inspections which are done on the fly? Is there any other trick to make IDEA faster?

It does not matter whether java version 1.4.2 or 1.5.0 is used it is always so slow. This powerbook has Mac OS X 10.4.1.

IDEA 4.5.4 seemed to be faster, although it is noticably slower on Mac than on Windows (probably better JVM on Windows).

8 comments
Comment actions Permalink

Though my performance is not as bad as yours, I did file a bug with some
cpu snapshots to help them determine what was going on. I suggest you
do the same, especially if you see a 10s delay on return. When you see
that, turn on cpu profiling do some work which shows slowness, and then
send in your snapshot.

R

0
Comment actions Permalink

Same problem as mine.
I tried also with a very trivial project (just e few files), but - of course - the symptom persists.

I own a MacBook Pro 2,4 Ghz with 4 Mb Ram: until now I had no experience of such poor performance.

0
Comment actions Permalink

Hi Damjan,

Did you change your Info.plist (/Applications/IntelliJ 9.app/Contents/Info.plist) ? One of the last lines contain the VM options. What I always do is increase the MaxPermSize (256m+) and the Max Heap Size (to 700m-1g). Maybe that helps?

Erik

0
Comment actions Permalink

I second this - Idea loves memory, and particularly if it doesn't have enough permgen performance can really suffer. The machine you describe seems fairly under-powered for editing a project of that size, especially the RAM. As Erik suggests, permgen of 256m (assuming you're using 32-bit Java) and a 784M heap will probably help a lot.

Cheers,
COlin

0
Comment actions Permalink

I'm on Windows and it is pathetically slow as well.  I turned off all the auto highlighting and syntax stuff like matching braces.  That helped some.

However, it still goes off to never never land quite often, even when I am not typing or compiling anything.

Where are the equivalent settings for Windows for memory?  And why isn't it configured for "real" development out of the box?  I have a high performance desktop.  It ought to be able to figure that out on its own.

0
Comment actions Permalink

On 12/22/09 00:39, Andrew Ressler wrote:

I'm on Windows and it is pathetically slow as well.  I turned off all the auto highlighting and syntax stuff like matching braces.  That helped some.

>

However, it still goes off to never never land quite often, even when I am not typing or compiling anything.

>

Where are the equivalent settings for Windows for memory?  And why isn't it configured for "real" development out of the box?  I have a high performance desktop.  It ought to be able to figure that out on its own.

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5253029#5253029


One thing I've noticed at my work is the presence of anything accessing
the file system can make a HUGE difference in performance when IDEA is
creating or reading indexes.  Anti-virus software, Google Desktop, etc.

Doug

0
Comment actions Permalink

Often when it hangs, it appears that nothing else is happening.  The Task Manager shows the machine pretty quiet.

0
Comment actions Permalink

I also encounter that a lot. More with IntelliJ 9 then with 8, but I always take a tea break than. I tried different VM configurations, different garbage collection strategies, etc, but not a solution yet. I think it has something to do with a connection timeout to some Maven repo or something, but I have no idea.

0

Please sign in to leave a comment.