IJ 14 completely ignores Code Style settings

In particular, the indentation is always 2 spaces chars on any file type.

How do I change it to use tabs?

I'm wasting about 2 hours every work day to manually reindent all the files...
This used to work with IDEA 13

Is there a secret Settings dialog somewhere? The File/Settings/Editor/Code Style dialogs are obviously useless, as you can see:
Screenshot-Settings.png

I have also double-checked that the xml settings file (~/.IntelliJIdea14/config/codestyles/Default\ _1_.xml) looks correct (that is: <option name="USE_TAB_CHARACTER" value="true" /> everywhere I want).

Any ideas?

Thank you

6 comments
Comment actions Permalink

Hello.

Please check Settings / ... / Code Style (the _top_ node):
1. Try to set Off "Detect and use existing file indents for editing".
2. If you are using EditorConfig, then try also set Off "Enable EditorConfig support".

Sorry for inconvenience. IDEA 14.1 will show a warning right in the editor, when the first option is On.

Regards,
Alexander.

0
Comment actions Permalink

Hello,

Thank you for your reply.

1. This option is off (in all default and project Settings) and is also completely ignored by IJIDEA. If it was actually working, the editor would keep using the existing styling of my files, which would have been acceptable.
2. I am not using EditorConfig

Any other ideas?

Thank you.

PS. as you can see in the screenshot of the posting, the code rendering on the right side does NOT match the settings on the left.

0
Comment actions Permalink

Hm, then I can't reproduce it. Even preview is Ok for me.

1. Please specify the exact IDEA build number.
2. Please attach the schema xml file.

Thank you,
Alexander.

0
Comment actions Permalink

IDEA build number:
IntelliJ IDEA 14.0.3
Build #IU-139.1117, built on January 21, 2015
JRE: 1.7.0_75-b13 amd64
OS: Linux CentOS 6.6 64bit



Attachment(s):
Default _1_.xml
0
Comment actions Permalink

Thanks.

One more point: could you reproduce the case with not updated preview, and check idea.log right after that. Are there any exceptions?

Thank you,
Alexander.

0
Comment actions Permalink

Problem solved by unchecking "Enable EditorConfig support". Thank you Alexander for your support.

0

Please sign in to leave a comment.