Linux editor doesn't work

  I'm running Ubuntu 9.10 with the 92.91 build of the professional beta (using a license for IDEA 8).  The editor doesn't seem to accept any "special" keys (pretty much anything non-alphabetic or non-shift, can't delete, navigate, anything).

  The IDE works otherwise, I can use control+key to run commands like build, alt+key to activate menus, etc.

  This doesn't happen on 90.122 (the official beta), but was happening in the last two EAP drops.

  Any work-arounds?

2 comments
Comment actions Permalink

Compiz and Java6 don't sit well together.
To get around this I use this script to start my Java IDEs in Ubuntu (actually Linux Mint )
http://ubuntuforums.org/showpost.php?p=3681245&postcount=2

Basically it turns off Compiz, replaces it with GDM then when you close the IDE, it restores Compiz.

0
Comment actions Permalink

Tried moving back to metacity just for a test, but the behaviour is the same:
- alphanumeric keys work (including Shift+alphas)
- alt+keys and control+keys works
- delete/backspace don't do anything
- nav keys try to scroll around (supposing you have a large enough file)

  It feels like there's a locked key somewhere, but nothing I can find: scroll lock is off, all other apps work, there's no weird graphical artifacts, no refresh issues.

  And most important of all, all versions of the EAP up to the beta (90.*) worked flawlessly, and none of the 92.* work.

  Any other ideas?

0

Please sign in to leave a comment.