ANT Started with Wrong JDK

I have a project composed of 4 modules with a project JDK of 1.5
However, one of the modules is set to not inherith the project JDK like the others, but use JDK6

When I run the ant build.xml that is within the JDK6 module it fails saying
javac: invalid target release: 1.6

If I set the project JDK to 1.6 it compile fine.

It seem like IDEA is using the Project JDK to launch ANT and not the module JDK.
Although I can set it in the properties, it should really pick it up by default

Please sign in to leave a comment.