2 comments
Comment actions Permalink

You can remove Keep When Reformating "Line breaks" option in IDE
Settings -> Code Style -> Alignement and Braces.

It should do what you expect.

Unfortunalely, for some reason, it's rather annoying to have IDEA not
keep line breaks when reformating. At least for me, in many cases I'd
rather have my line breaks kept.

What would be great is easier access to the configuration before
actually executing the reformat.
Maybe the reformat dialog box could be decorated with some more options?

So you could reformat with Keep or not keep line breaks very easily!

rgds

On 2009-12-01 05:30:16 +0900, opticyclic <no_reply@jetbrains.com> said:

I accidentally posted the details in the wrong forum before, but it
really bugs me so I am creating a link to it here.
http://www.jetbrains.net/devnet/thread/284504

Basically the Code Style doesn't format correctly if the line is
wrapped over multiple lines.
i.e. it doesn't move the code back onto a single line

---
Original message URL: http://www.jetbrains.net/devnet/message/5251294#5251294



0
Comment actions Permalink

Can't believe I missed that!
Thanks!

0

Please sign in to leave a comment.