Debugging AIR application on an Android x86 Virtual Machine

Hi,
I start by using adb to connect my Virtual Machine to the host.
I then tried to use the "network" debugging option, IDEA relaunch adb-server and henceforth kills the connection to the virtual machine and can't find the device.
I tried the USB debugging option, same results

Is there a way I missed to debug my app directly on the virtual machine?

Thanks for any help !

PS: I use an air-sdk able to deploy to x86 Android.

2 comments
Comment actions Permalink

IntelliJ uses ADT tool from the AIR SDK to start the app on the Android device. ADT tool in turn start ADB tool which is also bundled in AIR SDK. ADT docs don't say anything about installing/starting the app on the Android simulator, so I'm afraid it is not possible.
You may try to create apk package using Build | Package AIR Application, them manually install it on the Simulator and connect to IntelliJ using Remote Flash Debug run configuration (Run | Edit Configurations | [+] | Remote Flash Debug), but I never tried this way.

0
Comment actions Permalink

This way does work, tried it already, I was just trying to avoid the hassle of manually copying my build everytime I need a debug, but heh, at least I can step by step debug my application.
Thanks Alexander, as always, Jetbrains support rocks.

I'll try maybe to make ADT use my local ADB, with a symlink or something, I'll keep you posted.

0

Please sign in to leave a comment.