Invalid maximum heap size: -Xmx8192m

Answered

Hi,

I've changed within IntelliJ IDEA the maximum heap size to 8192m.
Appearantly, that's too high for IntelliJ IDEA.
But, and that's worser , IntelliJ IDEA does not startup again and leaves
the following message:

"Invalid maximum heap size: -Xmx8192m
The specified size exceeds the maximum representable size.
Could not create the Java virtual machine."

How do I get out of this?
In which IntelliJ IDEA configuration file is the "Xmx" parameter stored,
so I can patch it.
I did also not found a command line parameter to overide this setting.

Greetings from Belgium,

Johan

3 comments
Comment actions Permalink

Error: Intellij heap size snap

This answer is only for the linux/debian users.

So, I changed the max heap size from 750m to 2048m. When i changed this, I was unable to start the intellij.

Invalid maximum heap size: -Xmx2048m
The specified size exceeds the maximum representable size.
Could not create the Java virtual machine.

I installed the intellij by the help of snap. So, the contents of all the snaps where installed at /snap/intellij.

These contents were read-only. So, you cannot change the vmoptions here.

The actual customized vmoptions is present in the user directory.

The name of the directory is .IntelliJIdea{Year.Version}/config. Some of the operating systems hide this directory. So, you need to enable show the hidden files

Now, you will find the idea64.vmoptions file. Edit this file to the decrease the memory.
0

Please sign in to leave a comment.