[SOLVED] Ctrl + V and Ctrl + C doesn't work in intellij IDEA 14.0.2

I  can't copy and paste code in Intellij. I've been googling  for a couple  hours now. Every forum where there is a solution does not  work.
Ctrl + X works.
Ctrl + Z works.
Ctrl + V does not work.
Ctrl + C does not work

I'm using the latest version of Intellij Idea (14.0.2), I'm running  linux lite
Here is what happens when I right click:
I looked in setting and found keymap then typed copy in the search bar and this is what came up:

Please help :(


I think the problem is in the vim emulator. When I install intellij I installed all of the plugins that show up when you install cus lol.

So I re-installed without any plugins and it works!

Yes, the latest version for Linux comes with VIM. Just disable only the VIM plugin to go back to non-VIM style editing.


I don't have any vim plugin and when i try to copy from notepadd and past into intelij it dosen't work.(Intellij IDEA 15.0.3)

Any sugestions?



I've got the same problem, not only in IntelliJ Idea but also on PyCharm and AndroidStudio and I have not installed the IdeaVim plugin. I realised that when I click on the synchronize button both Ctrl+C and Ctrl+V work for a few seconds and then stop working again. Maybe there's a way to automate this synchronize action? I've been looking through the settings but have found nothing.

I've also realised that if I install the IdeaVim plugin and on Settings > Other Settings > Vim Emulator I select Ctrl+C and Ctrl+V to be handled by the IDE then both work. But I don't want to work with this option cause it also changes many other shortcuts I'm too used to them to switch them.


I'm running them all on Debian Stretch.



Try entering and exiting Vi and Vim in Terminal/the console.  That fixed this problem for me.

"vi" and "vim" to enter the text editors, then ":q" to exit them.

For my situation, I probably had an instance of Vi or Vim open from a Git comment amend.



If you want to paste code from elsewhere onto any Jetbrains application, simply copy paste code from outside, and go to your application; go to edit-> and then select 'Paste'


Thank you everyone for these answers. I had the same issue, and as I read these comments, suddenly I realised that I had installed the vim idea plugin, so after uninstalling, everything started working as normal.


Really annoying! I don't have vim plugin installed, but I open vi in terminal sometimes. Afterwards, the copy and paste become unreliable.

The solution is not use Intellij terminal.


@Jgr do you mean copy/paste in Terminal tool window or in IDE Editor? Can you please describe the exact steps to reproduce? And please post here (or upload somewhere) idea.log after IDE restart and screenshot of Settings(Preferences) | Tools | Terminal settings page. Thanks.


Hi Andrey Dernov. Thanks for the feedback. Sometimes I can't copy and paste in the IDE editor. How to reproduce? I don't know. Right now, from the feedback of other users, I'm trying to avoid using the vi inside the Intellij Terminal. In Terminal settings, I have all options selected. I don't have any VIM plugin installed in IntelliJ. I'll pay more attention to this issue, so I can provide proper feedback. I'm sorry for being so vague/fuzzy right now, but I didn't find a way to reproduce the issue yet.


I had the same problem in PhpStorm (2017-2018) IDE terminal.

Manjaro Linux 17.1.8 Hakoila + KDE Plasma 5.12.4 (!!!)

Turn off 'Override IDE shortcuts'
Settings | Tools | Terminal | Application settings -> Override IDE shortcuts

I didn't install IdeaVim plugin in IDE, only in the System.


In case you want to use Intellij IdeaVim and need to yank / paste  to and from X windows clipboard use following configuration in ~/.ideavimrc:

" yank/paste to/from system clipboard
map <leader>y "*y
map <leader>p "*p
set clipboard=unnamed

For me, such issue happened when I'm switched between desktop environments on my Ubuntu 18.04. So I did the following:

  1. Installed IdeaVim plugin
  2. Restarted IDE
  3. Uninstalled IdeaVim plugin
  4. Restarted IDE

Hope this will help someone. 


Had the same problem on Windows 10 running cmd.exe shell. This is how I fixed it.

Settings->Tools->Terminal Settings and unselect override IDE settings. Then restart PyCharm


I was reading all the comments and found a solution finally. Just follow the below steps.

> press ctrl+alt+s and once settings tab opens, just search "vim" on top left corner search box.

> select vim emulation and find where ctrl+c and ctrl+v is used.

> Click on drop down and change the value from vim to IDE so that these shortcuts will work fine for IDE


I had this annoying issue in PhpStorm Terminal last year from time to time and nothing helped to overcome it. The Victor Gryshko's advice really works, i.e. to install and uninstall the IdeaVim Plugin. Then finally in 2019 I can use the normal Copy-Paste functionality. JetBrains Team, would be nice to have this by default.


Installing/Un-installing plugin can not be related. If you have IdeaVIM installed and do not want to use VIM keybinding, make sure Tools | Vim Emulator mode is not enabled.


No, I had not IdeaVIM installed, as well as I did not use VIM keybinding. I have no Vim Emulator in Tools menu. Maybe the install/uninstall IdeaVim Plugin does not help, but then the issue was gone for a while. I have macOS Mojave now, the issue was also present at High Sierra.


I was having this issue WebStorm on Windows.  The solution for me was simple: Tools-> uncheck Vim (or just thype Ctrl-Alt-V which toggles VIM)


I was having trouble pasting into the Terminal in RubyMine on MacOS. None of the above worked for me. What did work was pasting using command + shift + v, which is supposedly the "paste with formatting" command. Even though this and all other copy/paste commands are greyed-out from the edit dropdown, the keyboard shortcut worked. Don't know why but quite frustrating.


Just use ctrl+insert for copy and shift+insert to paste


The issue still remains. I'm trying to copy text from website opened in Chrome and paste in internal PhpStorm terminal. All the described above methods don't fix the issue. Strange that it is marked as "solved".


MacOS 10.14.2
PhpStorm 2019.3


Just go to Tools and un-check Vim Emulator


problem solved here too,

on windows version,

disabled VIM emulator plugin.


thanks alot William Bryant.




This might be the problem of IdeaVim plugin also:-



I faced the same issue and in addition, other "broken" key binds and worked solution for me was:
on Ubuntu in "Region and Language" move English(US) language to the top of the list.


For me it was CAPS-LOCK enabled, CTRL-C, CTRL-V works only with disabled.


On the IDE settings find and select vim 

When Vim is selected find Ctrl+c and select IDE on the handler. Now the copy should work.

Same goes with Ctrl+v


I found Settings->Keymap had changed to Emacs instead of Windows.


Please sign in to leave a comment.