indent - Code Style -> Javascript -> Tabs and Indents

I am using WebStorm 9 on Ubuntu 14.04 . I have the Code Style -> Javascript -> Tabs and Indents set to the following:

Tab size: 4
Indent: 4
Continuation indent: 4

Despite that with Javascript files the tabs are still coming out as 2 spaces. I cannot make sense of this. What is going on? Does anyone know how to fix this simple thing?

P.S. I have the same problem with html files.

2 comments

Make sure that the option "Detect and use existing file indents for editing" is turned off (Settings|Editor|Code Style)

0

Thank you very much, Rustam!

0

Please sign in to leave a comment.