Cannot create gradle project on IntelliJ 13.1.6

When try to create a new gradle project
I kept getting the following error:

Error:Unable to start the daemon process.
This problem might be caused by incorrect configuration of the daemon.
For example, an unrecognized jvm option is used.
Please refer to the user guide chapter on the daemon at http://gradle.org/docs/2.2/userguide/gradle_daemon.html
Please read below process output to find out more:
-----------------------
Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine.


I am using gradle version 2.2, is there a setting somewhere that could fix this problem?
3 comments
Comment actions Permalink

try to set "VM options" to -Xmx512m at Settings | Build, Execution, Deployment | Build Tools | Gradle | Gradle VM options

0
Comment actions Permalink

Thank you for your suggestion but I have set it to -Xmx1024m -XX:MaxHeapSize=512m and it made no difference...

0
Comment actions Permalink

the error "Error occurred during initialization of VM. Could not reserve enough space for object heap" usually means that there is not enough memory on your machine.
So, try to use less that 1024, e.g. -Xmx512m or -Xmx256m also you can omit -XX:MaxHeapSize parameter

0

Please sign in to leave a comment.