Can I increase time out value?

When I want to update IDEA I often run into the problem of a time out. See excerpt of log file below. After retrying a few times the update can be downloaded. Also, I get time outs when trying to update certain plugins. I think the reason is some kind of slow connection because of company proxy, but I'm not sure. That's a big problem for us as all people in our company also have these issues.

Is there a way to increase the value of the timeout? I didn't find something in configuration or idea.properties.

2014-12-15 10:05:56,045 [ 124260]   INFO - ateSettings.impl.UpdateChecker - Read timed out
java.net.SocketTimeoutException: Read timed out
     at java.net.SocketInputStream.socketRead0(Native Method)
     at java.net.SocketInputStream.read(SocketInputStream.java:152)
     at java.net.SocketInputStream.read(SocketInputStream.java:122)
     at java.io.BufferedInputStream.fill(BufferedInputStream.java:235)
     at java.io.BufferedInputStream.read1(BufferedInputStream.java:275)
     at java.io.BufferedInputStream.read(BufferedInputStream.java:334)
     at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:687)
     at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:633)
     at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1323)
     at com.intellij.util.io.UrlConnectionUtil$InputStreamGetter.run(UrlConnectionUtil.java:111)
     at com.intellij.openapi.application.impl.ApplicationImpl$8.run(ApplicationImpl.java:405)
     at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
     at java.util.concurrent.FutureTask.run(FutureTask.java:262)
     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
     at java.lang.Thread.run(Thread.java:745)
     at org.jetbrains.ide.PooledThreadExecutor$1$1.run(PooledThreadExecutor.java:56)


Thanks for any hint.

Stefan

6 comments
Comment actions Permalink

Please try setting system property "idea.connection.timeout" (ms)

0
Comment actions Permalink

Thank you very much. In iea64.exe.vmoptions I set -Didea.connection.timeout=60000 and it now works fine.

Stefan

0
Comment actions Permalink

where in IntelliJ iDEA i can increase this timeout?

0
Comment actions Permalink

Pleas use Help | Edit Custom VM Options action to add `-Didea.connection.timeout=<value>`

0
Comment actions Permalink

Im using version :2016.3.4

 and not able to see the option "Edit Custom VM Options" 

0

Please sign in to leave a comment.