How can I disable auto-capitalization in SQL completion?

If I start typing "not nu" and accept the auto-completion it inserts "NOT NULL"

This is on IDEA 14.0.2 (with a MySQL database if it matters)

I remember that in IDEA 13 (with a SQL Server database) the auto-completion was smart enough to use the same case that I started with. "not nu" would be expanded to "not null" and "NOT NU" would be expanded to "NOT NULL".

Is there some configuration for this? Was the behavior changed in IDEA 14?

1 comment
Comment actions Permalink

Hello.

Please try Settings dialog / ... / Code Style / SQL / General / Word Case / Keywords = *Do not change*.

Regards,
Alexander.

1

Please sign in to leave a comment.