Totally disable antialiasing

Hello,

I am an experienced programmer and DBA but I am new to IntelliJ IDEA and also new to java. I use IDEA 14.0.1 (build 139.225) as first my IDEA.

I have a big trouble to read texts with any kind of smoothing fonts - fonts with anti aliasing. I feel dizzy if there are any smoothing texts on the screen. So I had to switch from Windows to Linux - LinuxMint 17 (Ubuntu Trusty) x64. Yes, I known that most people want smoothing texts but I'm not  the only one with this kind of problem. Many people I know accept smooth fonts but they would  prefer sharp font. They kind of long for Windows XP and some of them try to modify the registry to get some sharp texts.

I tried versions of java from openjdk7 x64 (default in ubuntu) to Oracle java 1.8.0_25 x64.

I set environment variable _JAVA_OPTIONS='-Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -Dawt.useSystemAAFontSettings=off -Dswing.aatext=false' . For most off java applications it is enough - nice sharp font and colours like in any other application.

I also add these options to idea.vmoptions and idea64.vmoptions and I set to disable antialiasing in settings - File-Settings-Editor-General-Appearance.

Most off IDEA is now sharp but some texts are still smooth
- all toolbars texts are smooth, for example on bottom toolbar texts "TODO", "Terminal"
- intellisence popup list (but hint under last row is sharp)
- Settings dialog - left side
- All or most combobox
- popup menu (in editor window, project or structure tree, ...) - after popup all items are smooth but after items get or lost focus become sharp, an item with submenu changes back to smooth after popup submenu is closed.

How can I totally disable the anti aliasing in IDEA ?

best regards
Tomas

PS: I am sorry for my English



Attachment(s):
IDEA-settings.png
IDEA.png

Please sign in to leave a comment.