[How To] Change Project Loaded When IntelliJ 14 Starts?

Sorry for the very basic question. I never had this issue with version 13 for some reason. But with 14, the IDE has chosen one of my apps as the default that it loads each time it starts. It just happens to be the biggest and slowest loading project that I work on the least. I've searched through the options and the web for where to change this setting. And either I'm using the wrong search criteria or ... well we won't go there. Any help guys?

3 comments
Comment actions Permalink

Hi Michael,

IDEA opens the last opened project, so once you started it, try reopening another project in the same window and restarting the IDE.

Alternativelly, you can check <YOUR_USER_HOME>/.IntelliJIdea14/config/options/recentProjects.xml and edit the linewhere the last path is stored.
<option name="lastPath" value="...">

Hope that helps,
Ivaylo

0
Comment actions Permalink

In addition to Ivaylo's comments, you can set IDEA to not open any project at start-up in the settings by turning off the option: Settings > Appearance & Behavior > System Settings > [Startup/Shutdown] > "Reopen last project on startup". With that turned off, at start-up you will get the welcome screen with a list of recent projects.

0
Comment actions Permalink

Thanks. You guys were both spot on. Don't know why I didn't see that option under "Startup / Shutdown". Works as expected now.

0

Please sign in to leave a comment.