Scala no longer works with 90.94 - suggestions?

Have been using 10781 along with scala and the scala power pack with reasonable success.

Have just installed 90.94 and now scala wont initialise on ide startup.

Tried going back to 10781 but scala no longer works with it either.

Any suggestions on how to get scala working again since the project is pretty much entirely written in it....

Excerpt from idea.log

2009-10-16 12:32:22,381 [   1961]  ERROR - ij.components.ComponentManager - scala/collection/Sequence [Plugin: Scala Power Pack]
com.intellij.diagnostic.PluginException: scala/collection/Sequence [Plugin: Scala Power Pack]
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:69)
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:27)
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.access$100(ComponentManagerImpl.java:67)
    at com.intellij.openapi.components.impl.ComponentManagerImpl.a(ComponentManagerImpl.java:78)
    at com.intellij.openapi.components.impl.ComponentManagerImpl.initComponents(ComponentManagerImpl.java:57)
    at com.intellij.openapi.components.impl.stores.ApplicationStoreImpl.load(ApplicationStoreImpl.java:9)
    at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:243)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:25)
    at com.intellij.idea.MainImpl$3.run(MainImpl.java:3)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
    at com.intellij.ide.IdeEventQueue.f(IdeEventQueue.java:57)
    at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:200)
    at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:93)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Caused by: java.lang.NoClassDefFoundError: scala/collection/Sequence
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:247)
    at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:79)
    ... 19 more
Caused by: java.lang.ClassNotFoundException: scala.collection.Sequence
    at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:70)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
    ... 22 more

2 comments
Comment actions Permalink

There's an updated release of the Scala plugin.

It works fine for me, using the latest IDEA EAP.

-tt

0
Comment actions Permalink

Thanks for the reply

Yes, I agree the latest scala plugin works with IU-90.94.

It seems the scala power pack still needs some sort of update to allow it to work.

Andreas

0

Please sign in to leave a comment.