Idea 14 refuses to copy large amount of text in editor

As long as the text is small enough, the paste action works. However, I meant to replace some of the html content of a file by copy/paste from chrome/source view. that didn't work. I tried the same from other tools, such as gedit (where the paste action works fine) and it still didn't work. The text I am copying has ~ 2000 lines.

Is somebody else able to reproduce this?

I am using linux mint 17, jdk 1.7.0_45

thanks

3 comments
Comment actions Permalink

I believe IDEA limits the size of the clip it will copy. IDEA 14 adds Rich Text copy capabilities, so that increases the size of clips due to the formatting. To the best of my knowledge, you cannot disable the Rich Text copy in the settings dialog. However, you can do it in the IDEA registry. You can also set the max size (in MBs) that Rich Text will copy. Keep in mind, modifying the latter may affect performance. To open the registry, type Ctrl+Alt+Shift+/. (I do not know what the shortcut is on the Mac). In there, there are the editor.richtext.enable and editor.richtext.max.size.megabytes entries you can modify (at your own risk since I've never played with those ;)).

0
Comment actions Permalink

Setting mentioned by Mark limits only the size of HTML/RTF content flavors when copying from IDEA to other editors, supporting rich text. Even if the limit is hit, plain text flavor won't be trimmed, so 'Paste Simple' (or some similarly named action) should paste the whole text in those editors.
But you seem to have a different issue - you try to copy text from other application and paste it into IDEA. Did I understand that correctly? If yes, could you check whether IDEA's 'Paste Simple' action works in your case?

0
Comment actions Permalink

thanks for your answers.

the simple paste doesn't copy anything.

Since no one is able to reproduce this I assume this is related to my specific environment (linux mint, xfce wm, etc).

Also, the actual jvm idea is using is 1.7.0_60, sorry for the confusion.

related to the registry workaround, I would rather create the file from some external editor instead.

0

Please sign in to leave a comment.