wildfly standalone.xml configuration overwritten during deployment

Hi,

I want to customize the wildfly 8.1 standalone.xml to increase logging. When I start the wildfly-8.1.0.Final/bin/standalone.sh everything is fine, the standalone.xml works with my configuration but when I run or debug the wildfly out of Intellij (13.1.5 on Mac OS 10.10), the standalone.xml is overwritten with defaults, so I cannot increase the wildfly logging.

My two questions:

  1. Can I disable this behavior?
  2. Where can I find the template for the Intellij-standalone.xml?


Thank you for any help.

1 comment
Comment actions Permalink
Hello,

IDEA indeed may sometimes alters standlone.xml, but only in exceptional circumstances.

That is, IDEA normally tries to undeploy artifacts deployed with a run configuration on the application server shutdown, but this is performed via server management interface and not by altering standalone.xml directly.
If undeploy on shutdown does not succeed (i.e. application server hangs and than killed by the user), only then IDEA cleans the <deployments> tag of the standalone.xml for artifacts not to be deployed
automatically on next startup (see https://youtrack.jetbrains.com/issue/IDEA-120403 for details).

Do you increase the WildFly logging by changing the content of a <deployment> tag of the standalone.xml?
If so, you may try to disable undeploy on shutdown by activating the 'Leave artifact deployed after disconnect' action for each of your artifacts.

Still I'm not sure if this will help, since <deployment> tag would be overwritten on redeploy on server startup anyway.
If nothing helps, please create a new youtrack and attach your standalone.xml (with the logging increased).

Regards,
Michael
0

Please sign in to leave a comment.