Maia build # 10762 breaks previously working Grails project

I've been following along with Maia and exercising Grails functionality with it.  When I upgraded to build # 10762 today it broke my working Grails project.  I'm using Sun JDK 1.6.0_13, Grails 1.1.1, and Groovy 1.6.3.  Groovy has a dependency on ASM version 2.2.3.

I'm getting a NoClassDefFoundError for org.objectweb.asm.Opcodes

Information:Compilation completed with 1 error and 0 warnings
Information:1 error
Information:0 warnings
Error:java.lang.NoClassDefFoundError: org/objectweb/asm/Opcodesat java.lang.ClassLoader.defineClass1(Native Method)at java.lang.ClassLoader.defineClass(ClassLoader.java:621)at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)at java.net.URLClassLoader.access$000(URLClassLoader.java:56)at java.net.URLClassLoader$1.run(URLClassLoader.java:195)at java.security.AccessController.doPrivileged(Native Method)at java.net.URLClassLoader.findClass(URLClassLoader.java:188)at java.lang.ClassLoader.loadClass(ClassLoader.java:307)at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)at java.lang.ClassLoader.loadClass(ClassLoader.java:252)at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)at org.jetbrains.groovy.compiler.rt.GroovycRunner.createCompilationUnit(GroovycRunner.java:342)at org.jetbrains.groovy.compiler.rt.GroovycRunner.main(GroovycRunner.java:116)Caused by: java.lang.ClassNotFoundException: org.objectweb.asm.Opcodesat java.net.URLClassLoader$1.run(URLClassLoader.java:200)at java.security.AccessController.doPrivileged(Native Method)at java.net.URLClassLoader.findClass(URLClassLoader.java:188)at java.lang.ClassLoader.loadClass(ClassLoader.java:307)at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)at java.lang.ClassLoader.loadClass(ClassLoader.java:252)at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)... 14 more



Do I need an upgrade to Groovy or Grails?  Please advise.
2 comments
Comment actions Permalink

I upgraded to Groovy 1.6.4 and the problem went away.  Thanks.

0
Comment actions Permalink

Upgaded to 10781, issue remains.

My environment is:
SDK Java 1.6.0_13, Grails 1.2-M2, Groovy 1.6.4

I've doublechecked all dependency trees, but all of them contain "asm" dependency.
Can't resolve, going to rollback to 10597 (that one worked for me)



Attachment(s):
screenshot43.png
0

Please sign in to leave a comment.