Maia build 10781 is deleting source files

This is a bit of a warning to those Maia users...

I was working on about three files, making a lot of changes and not sure exactly what I did but all of a sudden they were missing from the explorer view. I went to find them on disk and they were gone -- as were all my changes.

Well I thought EAP users beware and recreated the files the best I could and continued. About an hour later the two or three other files I was working on all dissapeared from the explorer and the disk -- along with all my changes.

I tried to figure out what operations I was doing when this happened but for the life of me other than opening and closing the associated editor panes, I have no clue. Then it happened again.

Needless to say I am warning those out there to backup early and often since whatever is going on is potentially quite destructive.

Erik

3 comments
Comment actions Permalink

You should be able to retrieve the deleted files via Local History. In the Project View, right click either the module or a directory and select Local history > Show History. Scroll down the list until you see your files and restore them via the one of the two Revert buttons (the lower one reverts everything associated with a history point in time and the upper one reverts anything selected in the tree view.)

0
Comment actions Permalink

FWIW, I've been working with 10781 for a week or so on a large project and haven't experienced this. Of course, most of the files I've been working with are existing files checked out from SCM, so maybe that makes a difference.

0
Comment actions Permalink

Thats pretty interesting since I just realized yesterday that the deleted files problem only happened on a module I was working on that I had not checked into (or out of) subversion. This had not happen on any checked in files (ironically)
-erik

0

Please sign in to leave a comment.