Module's "Dependencies" window - it's close to impossible to find a specific dependency :(

Hi,

Please, see the file attached - it's a screenshot of module's "Dependencies" window.
The only way that I've found for locating a specific dependency in this unsorted list (that may be huge) is start typing "Maven: org.apache...."
This typing is not comfortable and requires to remember full groupId:artifactId of the dependency that I'm looking for which is not practical, I think.

I have suffered with this window for a long time already so how about finding dependencies would be easier ?
Like providing a "Find" dialog or "locate on type" but don't require full groupId:artifactid to be entered - if any part matches, that's a match.

What do you think ?



Attachment(s):
1.png
3 comments
Comment actions Permalink

You can already type a leading asterisk, for example "*plexus"

0
Comment actions Permalink

No, it doesn't work for me.
I have, say, "Maven: org.apache.xbean:xbean-reflect:3.4" dependency but typing "*xbean" goes red right away.

Are we using the same build ? I'm running 10666 (oh, boy, what a build number)

0
Comment actions Permalink

Hm, I have top admit that I haven't tried Maja, nor have I tried with maven module names with blanks and colons in the names.

It _is_ working for me with simple names and with Diana build 9920.

0

Please sign in to leave a comment.