Subversion Handshake Failure

For some reason, the Subversion plugin has stopped working for me today. I'm getting an error saying:

Subversion: Received      fatal alert: handshake_failure

Please check Subversion SSL settings      (Settings | Version Control | Subversion | Network)

Maybe you should      specify SSL protocol manually - SSLv3 or TLSv1

I've tried changing the SSL protocal to TLSv1 (it was on SSLv3) but still get the same thing.

My mac did prompt me to do a java update this morning (which I did) so wonder if it's something to do with that?
Also wondered if it was something to do with the recent POODLE vulnerability discovered in SSLv3...?

Any ideas?

3 comments
Comment actions Permalink

I had yesterday same problem as you and also a colleague. He fixed with the next steps, but they are not working for me:

1.- Go to Preferences > Project settings > Version Control > Subversion
2.- In network tab, select TLSv1
3.- In general tab, click "Clear auth cache" and it will ask you again the credentials for the svn repositories.

As I said before, it worked for my colleague but not for me and I am still having the issue, so please let me know this fix works for you or if you have found any other solution.

Regards

0
Comment actions Permalink

Thanks Fran! That's fixed the problem for me. I had tried TLS1 before, but clearing the auth cache as well and restarting IntelliJ seems have sorted it.

0
Comment actions Permalink

Thanks! This worked for me as well in PHPStorm 6. Like Mark, I first tried using TLS but clearing the auth cache was also necessary.

0

Please sign in to leave a comment.