Active Editor preferences don't migrate through restart in IntelliJ IDEA 14 build number 139.1

I got a feeling that I'm doing/thinking something wrong but how to make the 'show white spaces' and 'show line numbers' preferences permanent?

12 comments
Comment actions Permalink

They should be permanent, without tricks. Works for me in recent 139.92. Any problems on your side?

Regards,
Alexander.

0
Comment actions Permalink

Yes the problem persists on my side. I deleted the whole thing, downloaded 139.92, and installed it; same.
The active editor settings got reset everytime I close and open the software.

Maybe it's a bug? How/Where to report?

0
Comment actions Permalink

Bug tracker is here: https://youtrack.jetbrains.com/issues/IDEA

You can file an issue at any time, ignoring my questions here - that's Ok. The problem is hardly in two settings you mentioned, it's more likely with saving files in the file system, maybe with file permissions.

What is your OS?

Regards,
Alexander.

0
Comment actions Permalink

I didn't ignore any question of yours. You asked "Any problems on your side?" That's quite a wide question, how can I know what kind of a problem you mean :)

My OS is Windows 8.1 Enterprise.

0
Comment actions Permalink

I just mean, if you are bored with this thread, you can write a bug report directly into the tracker.

Thank you, I'll ask our guys with Win8, do they know about similar issues.

Regards,
Alexander.

0
Comment actions Permalink

I'm not easily bored until I got my situation resolved :) but I did that report thing also:
https://youtrack.jetbrains.com/issue/IDEA-131382

0
Comment actions Permalink

Active Editor preferences persisting is not supported currently. Only global editor preferences (including both 'show line numbers' and 'show whitespaces') are preserved across restarts.

0
Comment actions Permalink

I could not find(not that I searched for years, but looked for them a while) the global editor preferences, would you kindly point me to the right direction? :)

0
Comment actions Permalink

The settings that you've mentioned are in Editor->Editor->Appearance.

0
Comment actions Permalink

Settings dialog / Editor / Editor / Appearance. (I thought we talked about them all this time, sorry for that.)

Regards,
Alexander.

0
Comment actions Permalink

Hahaha we suffered needlessly :( anyways thnx for the help guyz :)
I always was looking for these settings under the Appearance & Behavior tab under the settings :) (and yes I know I could search words through the settings but still looked it under the Appearance & Behavior tab and didn't even think to look to other tabs :D )

0
Comment actions Permalink

Just for case it helps: Settings dialog supports search. Just open the dialog and start typing a phrase, like "line numbers".

Regards,
Alexander.

0

Please sign in to leave a comment.