Ant Build not working after JDK + Ant relocation

Hi all

Using Maia #10597. I had to relocate my JDK and Ant due to some reasons. It seems to have reindexed all the files and I reconfigured the project JDK and also the default Ant for the project (which I have to use version 1.5.1 because of some limitations of our setup). However, my build files are all red now and in the Ant Build Window, the ant project name/targets don't show up, only the Intellij project name shows up w/o any targets underneath.

This view works all fine if I fire up Intellij 8.1.3. Any ideas?

Thanks,
CV

3 comments
Comment actions Permalink

Ok, couple of updates.

1. The same behaviour is exhibited in Intellij 8.1.3. I was wrong to say that the behaviour is not present in 8.1.3 - I assumed so because I saw the Ant Window have the project name and targets but on trying to build a target, it complained and when I put in the new Ant, it reverted to the same behaviour as in the Maia EAP.

2. If I use the bundled Ant 1.7.1, it works fine. Unfortunately, does me no good because we have dependency on 1.5.1 for one of our project modules.

Thanks in advance for help.

0
Comment actions Permalink

In case someone stumbles across the same problem, what solved it for me was to add the Ant 1.5.1 jars to the Additional Classpath tab. Sorry if this was a "Duh" moment for some but this was really news for me (that it can be solved thus). Anyways, I'm glad it worked cos I'd really reather use Ant from Intellij than from Cygwin.

Cheers!

0
Comment actions Permalink

Unfortunately, this has not yet completely resolved for me. When adding certain build files, targets are missing.

0

Please sign in to leave a comment.