Disabling blue balloon notification

Scenario: The package statement of a class has an error and I want to fix the package with alt + Enter.

Result: IntelliJ wants to be helpful and shows a blue notification (see screenshot). The balloon seems to “overwrite” my caret because when it’s displayed and I hit alt + Enter then I don’t get the option to move the class or reset the package but the class shown in the notification is imported. I always have to hit ESC first before hitting alt + Enter.

I already disabled all notifications with Preferences > Notifications > Display balloon notifications. But the blue annoyance still appears. Is there a way to suppress this notification?


Thank you kindly.



Attachment(s):
balloon.png
1 comment
Comment actions Permalink

It's not a balloon. Please check Settings / ... / Editor / Auto Import / Show import popup = No.

I personally use Show import popup = Yes, Add unambiguous imports on the fly = Yes. Then the most of imports are inserted automatically as I type, and blue popup is not seen also.

Regards,
Alexander.

0

Please sign in to leave a comment.